Mai 26, 2020, 03:46:55 pm


SMF - Just Installed!

Kronos 1.7.0 - missing dlls error

Démarré par curseofnight, Juillet 15, 2019, 11:35:58 am

« précédent - suivant »


Hello. Got problem, I hope you guys can help me with.

While the 32 bit version of Kronos 1.7.0 works great for me, whenever I try to run the 64 bit version of Kronos 1.7.0 I keep getting two errors; missing VCRUNTIME140D.DLL followed by missing ucrtbased.dll.

I did some research about these two .dll files and found this brief discussion on Microsoft's site:

According to that, they're debug versions of .dlls in vs2015 and you can remove the need for end users of your program to have them installed on their PCs if you compile your .exe in release mode and not debug mode, or by linking them to the .exe.... Which doesn't do me much good, haha.

The thing is, I already have both ms visual 2015 redist packages, x64 and x86, so feel like I'm out of options, so I came here to ask for advice.

This is a different PC from the one I mentioned awhile ago. The specs probably don't matter, but just in case it may be relevant somehow:

HP Pavilion Gaming Desktop 690
AMD Ryzen 5 2400G 3600 MHz 4 Cores
8 gigs of RAM
GeForce GTX 1050 2 gb driver ver. 391.25

Benjamin Siskoo

Hi Curseofnight,

We know about this problem, I added dll on the attachements. It should be working.

Thanks for your complete report (and spec are important :))


Juillet 16, 2019, 02:55:10 pm #2 Dernière édition: Juillet 16, 2019, 03:06:24 pm par curseofnight
Citation de: Benjamin Siskoo le Juillet 15, 2019, 08:52:05 pmThanks for your complete report (and spec are important :))

You're welcome. And thanks for the dlls. :)

Kronos 1.7.0 64bit starts now but there are sound issues in both Deep Fear and Resident Evil and the some of the video options are (seemingly) broken. I checked the 32 bit version and it's the same(I didn't actually have a chance to play anything yesterday). :(

Kronos 1.6.0 doesn't have any problems, for me at least, so it's ok.

Edit: Also, I noticed that silly Kronos = Love topic I made awhile ago wasn't actually in the Kronos section, lol, sorry about that!

Benjamin Siskoo

Weird, try this : delete (or backup it) your kronos.ini and yabause.ini.

You can get from these paths : C:\Users\username\AppData\Local\Kronos and/or C:\Users\username\AppData\Local\Yabause.

Delete or backup the bkram.bin file too.

Try again.

Do you use real games or Iso from the net ?

No problem with your Kronos = love topic :)


Juillet 16, 2019, 09:22:10 pm #4 Dernière édition: Juillet 22, 2019, 08:33:38 am par curseofnight
I forgot to mention my OS before; it's Windows 10 64 bit.

I play ISOs of Deep Fear and Resident Evil created from legal discs. They're the only Saturn games I care about, lol.
(Edit 2: Actually, I just double checked, their not ISOs. Each one has a .ccd, .img, and .sub file. I launch the .ccd files through File->Eject/Load ISO.)

In fact, it's mainly Deep Fear I care about as the PC version of Resident Evil is the better version, imo(no 'floating' polygons, higher resolution, modding tools, etc.) I just purchased RE cause I wanted a particular texture for model I never finished.(No idea how to rip stuff from Saturn games, btw. My plan was to bump up the settings and take a screenshot then run it through some filters in GIMP, but I lost interest and moved on, heh.)

Anyway, back on topic, I deleted the kronos.ini and bkram.bin from appdata\local\kronos but it didn't help. I couldn't find a yabause folder though.

Actually, I couldn't find a Kronos folder at first either. Then, I remembered that you could set a custom path for the bkram.bin in kronos so I started it up, went to settings->cart/memory and clicked the '...' button with the intent of making a new one in a temp folder, and was taken straight to the appdata\local\kronos folder. I then closed the window and exited Kronos, went back to appdata\local and there the Kronos folder was, heh. I'm 100% positive it wasn't there before because it's right above the Lazarus folder(free Pascal compiler) and I stopped and checked that out for second so I'm sure I would've seen it.

I tried doing the same thing with Kronos 1.6.0 as by default it points to the appdata\local\yabause for it's bkram.bin but when I tried I, it just opened the folder where the kronos.exe is for 1.6.0, so no dice.

Probably a good thing though, as I don't really wanna mess with 1.6.0 to much as it runs Deep Fear great.

Edit: One last thing. I did some experimenting trying to fix the sound issues by changing various settings (toggling multi-threading on/off, changing bios region, etc.,etc.) and I noticed the sound issues where worse with v-sync off. V-sync seemed to be the only setting that affected it at all.

Benjamin Siskoo

Juillet 18, 2019, 05:53:09 pm #5 Dernière édition: Juillet 18, 2019, 10:15:24 pm par Benjamin Siskoo
I don't forgot you, I'll answer later this week ^^


Benjamin Siskoo

Give me your mail, I'll send you a wip to test

could you add some bug report here : (your edit about the sond for example)


Juillet 19, 2019, 11:12:03 pm #8 Dernière édition: Juillet 26, 2019, 03:00:55 am par curseofnight
Citation de: Benjamin Siskoo le Juillet 19, 2019, 08:26:08 amGive me your mail, I'll send you a wip to test
Not interested, sorry.

Citation de: Benjamin Siskoo le Juillet 19, 2019, 08:26:08 amcould you add some bug report here : (your edit about the sond for example)
Hmm... Maybe. I download stuff from GitHub quite often but I don't have an account there so I've never done that before. GitHub's a place for smart people; I might make myself look stupid, lol.

Btw, I noticed your avatar on GitHub is Caprica 6. I'm an Athena fan myself. :)

Edit: Ok, I made a GitHub account and posted an issue on the page you linked. I hope that was the right way to do it, hehe.

Benjamin Siskoo

Ok nice, François is working on anything else, but your report will be fixed in the future, thanks :)